Direct Contact Integrations Closing Requests without Completion after 14 Day Due Date
Incident Report for DataGrail
Resolved
This incident has been resolved.
Posted Oct 11, 2022 - 16:42 PDT
Identified
We have identified an issue with Direct Contact Integrations that have reached their 14-day expiration date and are set to "Contact My Team".

Intended Behavior : At the 14 day expiration date, if the Direct Contact integration has not been completed by the designated email processor and is set to "Contact My Team", the Super Admin will get a notification to reach out to the designated email processor and the request will remain open until either the Request Processor/Super Admin manually stops processing OR the designated email processor for the Direct Contact integration completes the task.

Current Behavior : At the 14 expiration date, if the Direct Contact integration has not been completed by the designated email processor and is set to "Contact My Team", the Super Admin is getting a notification still but the Direct Contact integration is marking itself as complete without the influence of the Request Processor/Super Admin or the task being actioned by the designated email processor, thus causing the request to close when all other integrations have completed.

We are actively investigating and will post updates as we learn more.
Posted Oct 11, 2022 - 14:29 PDT
This incident affected: Request Manager.