Issue with Direct Contact Deletions (Resolved)
Incident Report for DataGrail
Resolved
Today (8/25/2021) we identified and resolved an issue with Deletions in which privacy requests were automatically closed before a response was recorded from Direct Contact Integrations.

We have reset all affected privacy requests back to a “Pending Delete” state. No data or requests were lost. Please review your queue and process requests as you would normally.

If you have any questions please contact support@datagrail.io.
Posted Aug 25, 2021 - 21:16 PDT
This incident affected: Request Manager.