Issue Detected with Smart Verification

Incident Report for DataGrail

Resolved

This incident has been fully resolved and the platform is functioning normally.
Posted May 05, 2021 - 14:13 PDT

Monitoring

We have resolved the issue with Smart Verification and we are currently monitoring for any issues.

We have resent verification emails to all requesters that encountered an error when attempting to verify their privacy request.
Posted May 05, 2021 - 14:03 PDT

Update

We are continuing work on a fix for this and will post updates as we learn more.
Posted May 05, 2021 - 13:29 PDT

Update

We are actively working on a fix for this and will post updates as we learn more.
Posted May 05, 2021 - 12:51 PDT

Identified

We have identified an issue with certain flows for our Smart Verification service. We will post updates as soon as more information is available.
Posted May 05, 2021 - 12:23 PDT
This incident affected: Request Manager.