Direct Contact Form Submission Error

Incident Report for DataGrail

Resolved

This issue has been resolved!
Posted Aug 26, 2025 - 13:39 PDT

Monitoring

A fix has been implemented and we are monitoring results.
Posted Aug 26, 2025 - 12:56 PDT

Identified

The issue has been identified and we are working on a resolution.
Posted Aug 26, 2025 - 11:16 PDT

Investigating

Some customers have reported Direct Contact Processors are unable to submit request results. We believe this to be an isolated issue and are urgently investigating.
Posted Aug 26, 2025 - 09:58 PDT
This incident affected: Request Manager.