Intake Form Submission Errors

Incident Report for DataGrail

Resolved

This incident has been resolved and all users are able to submit Privacy Requests.
Posted Aug 12, 2024 - 11:31 PDT

Identified

Users are experiencing an error when attempting to submit a Privacy Request. The issue has been identified and we are working on resolution
Posted Aug 12, 2024 - 10:28 PDT
This incident affected: Intake Forms.