Data Subject Requesters Unable to Verify Email Address
Incident Report for DataGrail
Resolved
This incident has been fully resolved and the platform is functioning normally.
Posted Feb 10, 2022 - 11:00 PST
Monitoring
We have resolved the issue with data subject requesters hitting an error when attempting to verify their email address and we are currently monitoring for any issues.
Posted Feb 10, 2022 - 09:21 PST
Identified
We have identified an issue with data subject requesters hitting an error when attempting to verify their email address.

We are actively investigating and will post updates as we learn more.
Posted Feb 10, 2022 - 08:18 PST
This incident affected: Request Manager.